BOINC@Poland

Zaloguj się lub zarejestruj.

Zaloguj się podając nazwę użytkownika, hasło i długość sesji
Szukanie zaawansowane  

Aktualności:

Czy uczestniczysz w Projekcie miesiąca?

Strony: [1]   Do dołu

Autor Wątek: Problem z czujką - Linux - system nie wykrywa  (Przeczytany 1571 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Rysiu

  • Liczydłowy
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 1 081
    • Zobacz profil
Problem z czujką - Linux - system nie wykrywa
« dnia: 24 Luty 2017, 17:28 »

Ahoj Kamraci!

Mam problem z czujką na Linux. Na Windows śmiga ale na Pingwinie nie chce za nic...

lsusb zwraca m.in:

Cytuj
Bus 002 Device 013: ID 16c0:05df Van Ooijen Technische Informatica HID device except mice, keyboards, and joysticks

Z tego co wydedukowałem to jest właśnie czujka.

sensors.xml to:

Cytuj
<sensors>
  <sensor>
    <hardware_id>16c0:05df</hardware_id>
    <revision>257</revision>
    <revision_bcd>1.01</revision_bcd>
    <vendor>obdev.at</vendor>
    <product>DataStore</product>
    <usb_protocol>1</usb_protocol>
    <options>
      <switch_gmsupply>1</switch_gmsupply>
      <txt_line1>1</txt_line1>
      <txt_line2>1</txt_line2>
      <reset_counters>1</reset_counters>
      <switch_buzzer>1</switch_buzzer>
      <switch_backlight>1</switch_backlight>
    </options>
  </sensor>
  <sensor>
    <hardware_id>16c0:05df</hardware_id>
    <revision>513</revision>
    <revision_bcd>2.01</revision_bcd>
    <vendor>obdev.at</vendor>
    <product>radioactiveathome.org GRS</product>
    <usb_protocol>1</usb_protocol>
    <options>
      <switch_gmsupply>1</switch_gmsupply>
      <reset_counters>1</reset_counters>
      <switch_buzzer>1</switch_buzzer>
      <switch_backlight>1</switch_backlight>
    </options>
  </sensor>
  <sensor>
    <hardware_id>16c0:05df</hardware_id>
    <revision>593</revision>
    <revision_bcd>2.51</revision_bcd>
    <vendor>obdev.at</vendor>
    <product>radioactiveathome.org GRS</product>
    <usb_protocol>1</usb_protocol>
    <options>
      <reset_counters>1</reset_counters>
      <switch_buzzer>1</switch_buzzer>
      <switch_backlight>1</switch_backlight>
    </options>
  </sensor>
  <sensor>
    <hardware_id>16c0:05df</hardware_id>
    <revision>594</revision>
    <revision_bcd>2.52</revision_bcd>
    <vendor>obdev.at</vendor>
    <product>radioactiveathome.org GRS</product>
    <usb_protocol>1</usb_protocol>
    <options>
      <reset_counters>1</reset_counters>
      <switch_buzzer>1</switch_buzzer>
      <switch_backlight>1</switch_backlight>
      <buzzer_alert>1</buzzer_alert>
      <lcd_avg_opts>1</lcd_avg_opts>
    </options>
  </sensor>
  <sensor>
    <hardware_id>16c0:05df</hardware_id>
    <revision>595</revision>
    <revision_bcd>2.53</revision_bcd>
    <vendor>obdev.at</vendor>
    <product>radioactiveathome.org GRS</product>
    <usb_protocol>1</usb_protocol>
    <options>
      <reset_counters>1</reset_counters>
      <switch_buzzer>1</switch_buzzer>
      <switch_backlight>1</switch_backlight>
      <buzzer_alert>1</buzzer_alert>
    </options>
  </sensor>
  <sensor>
    <comment>3.01</comment>
    <hardware_id>04d8:f6fe</hardware_id>
    <revision>769</revision>
    <revision_bcd>3.01</revision_bcd>
    <vendor>microchip</vendor>
    <product>radioactiveathome.org GRS</product>
    <usb_protocol>1</usb_protocol>
    <options>
      <switch_gmsupply>1</switch_gmsupply>
      <reset_counters>1</reset_counters>
      <switch_buzzer>1</switch_buzzer>
      <switch_backlight>1</switch_backlight>
    </options>
  </sensor>
  <sensor>
    <comment>2.60</comment>
    <hardware_id>16c0:05df</hardware_id>
    <revision>608</revision>
    <revision_bcd>2.60</revision_bcd>
    <vendor>radioactiveathome.org</vendor>
    <product>Radiation Detector KIT</product>
    <usb_protocol>1</usb_protocol>
    <options>
      <switch_gmsupply>1</switch_gmsupply>
      <reset_counters>1</reset_counters>
      <switch_buzzer>1</switch_buzzer>
      <switch_backlight>1</switch_backlight>
    </options>
  </sensor>
</sensors>

W stderr mam natomiast:

Cytuj
Radac $Rev: 585 $ starting...
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Could not find any of the devices listed in sensors.xml: Device communication error
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
Warning: cannot query manufacturer for device: error sending control message: Operation not permitted

Kombinowałem (odpalałem z uprawnieniami sudo i normalnie) ale nic z tego nie wyszło.
Co może być nie tak?
Zapisane

Rysiu

  • Liczydłowy
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 1 081
    • Zobacz profil
Problem z czujką - Linux - system nie wykrywa
« Odpowiedź #1 dnia: 24 Luty 2017, 18:55 »

Po konsultacji z RAD-Poland zatrybiło  :attack: :attack: :attack:

Link dla potomnych: http://www.boincatpoland.org/smf/radioactivehome/uruchomienie-czujnika-w-systemie-linux/
Zapisane
Strony: [1]   Do góry
 

SMF spam blocked by CleanTalk