BOINC@Poland

Zaloguj się lub zarejestruj.

Zaloguj się podając nazwę użytkownika, hasło i długość sesji
Szukanie zaawansowane  

Aktualności:

Czy uczestniczysz w Projekcie miesiąca?

Strony: 1 [2]   Do dołu

Autor Wątek: AstroPulse na GPU ATI  (Przeczytany 25649 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

apohawk

  • Leń
  • Newsmani
  • BOINC Fanatyk
  • *
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 3 058
  • Ask no questions, hear no lies.
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #40 dnia: 04 Luty 2011, 21:56 »

Ustaw co tam lubisz a Collatza lub PG jako zapasowy, resource share 0 w preferencjach na stronie projektu. Ulubiony wyschnie, policzy się trochę zapasowy.
Zapisane
No good deed goes unpunished.

lolek

  • Grupa Reagowania Operacyjno-Manewrowego
  • BOINC Hooligans
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 4 321
  • Patrzę w gwiazdy
    • Zobacz profil
    • boinc- przetwarzanie rozproszone
Odp: AstroPulse na GPU ATI
« Odpowiedź #41 dnia: 04 Luty 2011, 22:20 »

Dokładnie tak jak pisze apohawk. Ja tak liczę milkę a w zapasie PG.
Zapisane

Karol007

  • Bywalec forum
  • **
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 48
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #42 dnia: 05 Luty 2011, 01:15 »

Dokładnie tak jak pisze apohawk. Ja tak liczę milkę a w zapasie PG.

Właśnie... z Milki też na GPU nic nie mam (trochę obok tematu - sorry).
Zapisane

lolek

  • Grupa Reagowania Operacyjno-Manewrowego
  • BOINC Hooligans
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 4 321
  • Patrzę w gwiazdy
    • Zobacz profil
    • boinc- przetwarzanie rozproszone
Odp: AstroPulse na GPU ATI
« Odpowiedź #43 dnia: 05 Luty 2011, 07:46 »

Bo milka zarówno w przypadku NV jak i ATI wymaga podwójnej precyzji. A u zielonych to chyba dopiero od kart GTX2xx wprowadzili.
Zapisane

Krzysiak

  • Starszy Liczydłowy
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 2 529
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #44 dnia: 06 Luty 2011, 21:30 »

Co może być powodem że cały czas wywala komunikat ?
2011-02-06 21:25:46   SETI@home   Started download of 28au10ac.7197.9474.11.10.21
2011-02-06 21:25:48   SETI@home   Temporarily failed download of 28au10ac.7197.9474.11.10.21: HTTP error
2011-02-06 21:25:48   SETI@home   Backing off 23 min 26 sec on download of 28au10ac.7197.9474.11.10.21
Zapisane


>>Moja szczegółowa sygnatur<< %)                                      >> Spis moich odkrytych liczb pierwszych << :whistle:

Troll81

  • Troll forumowy
  • Newsmani
  • Starszy Kalkulator
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 32 521
  • Owoc żywota twojego je ZUS
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #45 dnia: 06 Luty 2011, 21:33 »

problem po stronie serwera?
Zapisane

Krzysiak

  • Starszy Liczydłowy
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 2 529
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #46 dnia: 17 Luty 2011, 09:13 »

Jest nieźle po 2 tygodniach w końcu pobrało mi jedną całą próbkę dla GPU  XD
Zapisane


>>Moja szczegółowa sygnatur<< %)                                      >> Spis moich odkrytych liczb pierwszych << :whistle:

Szopler

  • Radioaktywny
  • Grupa Reagowania Operacyjno-Manewrowego
  • Kalkulator
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 552
    • Zobacz profil
    • szoplik.pl
Odp: AstroPulse na GPU ATI
« Odpowiedź #47 dnia: 17 Luty 2011, 12:43 »

Tak ENHANCED punktuje - LLynk

Próbek AP jakoś nie widać...
Zapisane

Krzysiak

  • Starszy Liczydłowy
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 2 529
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #48 dnia: 17 Luty 2011, 19:37 »

Są próbki dużo próbek  ;D czas raportowania początek kwietnia  :)

Kto ma sentyment niech pobiera ile się da
Zapisane


>>Moja szczegółowa sygnatur<< %)                                      >> Spis moich odkrytych liczb pierwszych << :whistle:

mimeq

  • Starszy Liczydłowy
  • ****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 1 788
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #49 dnia: 19 Luty 2011, 11:56 »

Cos tam licze:

http://setiathome.berkeley.edu/results.php?hostid=5590258

Ale zamulka kompa jest konkretna, wiec liczy sie tylko jak nie uzywam kompa ...
Zapisane

Krzysiak

  • Starszy Liczydłowy
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 2 529
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #50 dnia: 19 Luty 2011, 20:54 »

HD5850 liczy bezproblemowo - http://setiathome.berkeley.edu/results.php?hostid=5705440&offset=0&show_names=0&state=3&appid=

HD4770 sypie błędami i nic nie przeliczyło - http://setiathome.berkeley.edu/results.php?hostid=5708444&offset=0&show_names=0&state=4&appid=
Zapisane


>>Moja szczegółowa sygnatur<< %)                                      >> Spis moich odkrytych liczb pierwszych << :whistle:

mimeq

  • Starszy Liczydłowy
  • ****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 1 788
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #51 dnia: 19 Luty 2011, 21:09 »

Hmm czemu mi pobiera tylko Astropulse ???  :book:

U Ciebie widze SETI@home Enhanced. Moze nie bedzie tak mulic kompa na Enhanced ?
Zapisane

Krzysiak

  • Starszy Liczydłowy
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 2 529
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #52 dnia: 20 Luty 2011, 16:49 »

SETI@home Enhanced
Zaznaczone tylko wszystko do pobierania

czas przeliczeń od 20s -0,02 pkt
do 30-60 minut coś koło 40-50 pkt
na HD5850
« Ostatnia zmiana: 20 Luty 2011, 16:54 wysłana przez Krzysiak_PL_GDA »
Zapisane


>>Moja szczegółowa sygnatur<< %)                                      >> Spis moich odkrytych liczb pierwszych << :whistle:

Szopler

  • Radioaktywny
  • Grupa Reagowania Operacyjno-Manewrowego
  • Kalkulator
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 552
    • Zobacz profil
    • szoplik.pl
Odp: AstroPulse na GPU ATI
« Odpowiedź #53 dnia: 20 Luty 2011, 17:28 »

App_info.xml na którym chodzą Enhanced i AP:

<app_info>
    <app>
        <name>setiathome_enhanced</name>
    </app>
    <file_info>
        <name>AK_v8b_win_x64_SSE41.exe</name>
        <executable/>
    </file_info>
    <app_version>
        <app_name>setiathome_enhanced</app_name>
        <version_num>603</version_num>
<platform>windows_intelx86</platform>
        <file_ref>
           <file_name>AK_v8b_win_x64_SSE41.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>
    <app_version>
        <app_name>setiathome_enhanced</app_name>
        <version_num>603</version_num>
<platform>windows_x86_64</platform>
        <file_ref>
           <file_name>AK_v8b_win_x64_SSE41.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>
    <app>
        <name>astropulse_v505</name>
    </app>
    <file_info>
        <name>ap_5.05r409_SSE.exe</name>
        <executable/>
    </file_info>
    <app_version>
        <app_name>astropulse_v505</app_name>
        <version_num>505</version_num>
<platform>windows_intelx86</platform>
        <file_ref>
            <file_name>ap_5.05r409_SSE.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>   
    <app_version>
        <app_name>astropulse_v505</app_name>
        <version_num>505</version_num>
<platform>windows_x86_64</platform>
        <file_ref>
            <file_name>ap_5.05r409_SSE.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>
<app_info>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>MB_6.10_win_SSE3_ATI_HD5_r177.exe</name>
<executable/>
</file_info>
<file_info>
<name>MultiBeam_Kernels.cl</name>
<executable/>
</file_info>


<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_intelx86</platform>
<avg_ncpus>0.05</avg_ncpus>
<max_ncpus>0.05</max_ncpus>
<plan_class>ati13ati</plan_class>
        <cmdline>-period_iterations_num 2 -instances_per_device 1 -hp</cmdline>
        <flops>20987654321</flops>
<file_ref>
<file_name>MB_6.10_win_SSE3_ATI_HD5_r177.exe</file_name>
<main_program/>
</file_ref>
    <file_ref>
        <file_name>MultiBeam_Kernels.cl</file_name>
        <copy_file/>
    </file_ref>
   <coproc>
   <type>ATI</type>
   <count>1</count>
   </coproc>
</app_version>
<app_info>
<app>
<name>astropulse_v505</name>
</app>
<file_info>
        <name>ap_5.06_win_x86_SSE2_OpenCL_ATI_r456.exe</name>
        <executable/>
    </file_info>
<file_info>
    <name>AstroPulse_Kernels.cl</name>
    <executable/>
</file_info>
    <app_version>
        <app_name>astropulse_v505</app_name>
        <version_num>506</version_num>
<avg_ncpus>0.01</avg_ncpus>
<max_ncpus>0.05</max_ncpus>
                <plan_class>ati13ati</plan_class>
                <cmdline>-ffa_block 8192 -ffa_block_fetch 2048</cmdline>
          <coproc>
              <type>ATI</type>
        <count>1</count>
          </coproc>
        <flops>15987654321</flops>

        <file_ref>
            <file_name>ap_5.06_win_x86_SSE2_OpenCL_ATI_r456.exe</file_name>
            <main_program/>                           
        </file_ref>
<file_ref>
    <file_name>AstroPulse_Kernels.cl</file_name>
    <copy_file/>
</file_ref>
    </app_version>
Zapisane

mimeq

  • Starszy Liczydłowy
  • ****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 1 788
    • Zobacz profil
Odp: AstroPulse na GPU ATI
« Odpowiedź #54 dnia: 20 Luty 2011, 21:47 »

App_info.xml na którym chodzą Enhanced i AP:

<app_info>
    <app>
        <name>setiathome_enhanced</name>
    </app>
    <file_info>
        <name>AK_v8b_win_x64_SSE41.exe</name>
        <executable/>
    </file_info>
    <app_version>
        <app_name>setiathome_enhanced</app_name>
        <version_num>603</version_num>
<platform>windows_intelx86</platform>
        <file_ref>
           <file_name>AK_v8b_win_x64_SSE41.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>
    <app_version>
        <app_name>setiathome_enhanced</app_name>
        <version_num>603</version_num>
<platform>windows_x86_64</platform>
        <file_ref>
           <file_name>AK_v8b_win_x64_SSE41.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>
    <app>
        <name>astropulse_v505</name>
    </app>
    <file_info>
        <name>ap_5.05r409_SSE.exe</name>
        <executable/>
    </file_info>
    <app_version>
        <app_name>astropulse_v505</app_name>
        <version_num>505</version_num>
<platform>windows_intelx86</platform>
        <file_ref>
            <file_name>ap_5.05r409_SSE.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>   
    <app_version>
        <app_name>astropulse_v505</app_name>
        <version_num>505</version_num>
<platform>windows_x86_64</platform>
        <file_ref>
            <file_name>ap_5.05r409_SSE.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>
<app_info>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>MB_6.10_win_SSE3_ATI_HD5_r177.exe</name>
<executable/>
</file_info>
<file_info>
<name>MultiBeam_Kernels.cl</name>
<executable/>
</file_info>


<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_intelx86</platform>
<avg_ncpus>0.05</avg_ncpus>
<max_ncpus>0.05</max_ncpus>
<plan_class>ati13ati</plan_class>
        <cmdline>-period_iterations_num 2 -instances_per_device 1 -hp</cmdline>
        <flops>20987654321</flops>
<file_ref>
<file_name>MB_6.10_win_SSE3_ATI_HD5_r177.exe</file_name>
<main_program/>
</file_ref>
    <file_ref>
        <file_name>MultiBeam_Kernels.cl</file_name>
        <copy_file/>
    </file_ref>
   <coproc>
   <type>ATI</type>
   <count>1</count>
   </coproc>
</app_version>
<app_info>
<app>
<name>astropulse_v505</name>
</app>
<file_info>
        <name>ap_5.06_win_x86_SSE2_OpenCL_ATI_r456.exe</name>
        <executable/>
    </file_info>
<file_info>
    <name>AstroPulse_Kernels.cl</name>
    <executable/>
</file_info>
    <app_version>
        <app_name>astropulse_v505</app_name>
        <version_num>506</version_num>
<avg_ncpus>0.01</avg_ncpus>
<max_ncpus>0.05</max_ncpus>
                <plan_class>ati13ati</plan_class>
                <cmdline>-ffa_block 8192 -ffa_block_fetch 2048</cmdline>
          <coproc>
              <type>ATI</type>
        <count>1</count>
          </coproc>
        <flops>15987654321</flops>

        <file_ref>
            <file_name>ap_5.06_win_x86_SSE2_OpenCL_ATI_r456.exe</file_name>
            <main_program/>                           
        </file_ref>
<file_ref>
    <file_name>AstroPulse_Kernels.cl</file_name>
    <copy_file/>
</file_ref>
    </app_version>

Szopler znalazlem wszystko oprocz :

AK_v8b_win_x64_SSE41.exe
ap_5.05r409_SSE.exe

 :book: :book:
Zapisane

Szopler

  • Radioaktywny
  • Grupa Reagowania Operacyjno-Manewrowego
  • Kalkulator
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 552
    • Zobacz profil
    • szoplik.pl
Odp: AstroPulse na GPU ATI
« Odpowiedź #55 dnia: 20 Luty 2011, 21:50 »

Bo to pewnie jakieś stare wpisy są...
Zapisane

mimeq

  • Starszy Liczydłowy
  • ****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 1 788
    • Zobacz profil
AstroPulse na GPU ATI
« Odpowiedź #56 dnia: 25 Kwiecień 2011, 22:15 »

Z sentymentu postanowilem dociagnac seti do 1M, liczy sie w miare szybko bo okolo 30min za 1xx pkt (SETI@home Enhanced).

Dwa minusy jakie widze to:
1.Jeden rdzen GPU pozera 1 rdzen CPU
2.Czas validacji - mam tego juz ~100 szt (w pendingu) a liczy sie na 1 rdzeniu 5970 i to nie caly czas.

Astropulse zlapalem 3 szt liczyly sie okolo 4h. Jedno WU juz potwierdzone i zniklo, nie kojarze jaki byl urobek punktowy.

http://setiathome.berkeley.edu/results.php?hostid=5590258&offset=0&show_names=0&state=2&appid=0
Zapisane

Krzysiak

  • Starszy Liczydłowy
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 2 529
    • Zobacz profil
AstroPulse na GPU ATI
« Odpowiedź #57 dnia: 25 Maj 2011, 22:40 »

Tak sentymentu i ciekawości powracam do tematu  

Co z tego zostawić aby na GPU liczyło tylko AstroPulse ?
<app_info>
    <app>
        <name>setiathome_enhanced</name>
    </app>
    <file_info>
        <name>AK_v8b_win_x64_SSE41.exe</name>
        <executable/>
    </file_info>
    <app_version>
        <app_name>setiathome_enhanced</app_name>
        <version_num>603</version_num>
<platform>windows_intelx86</platform>
        <file_ref>
           <file_name>AK_v8b_win_x64_SSE41.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>
    <app_version>
        <app_name>setiathome_enhanced</app_name>
        <version_num>603</version_num>
<platform>windows_x86_64</platform>
        <file_ref>
           <file_name>AK_v8b_win_x64_SSE41.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>
    <app>
        <name>astropulse_v505</name>
    </app>
    <file_info>
        <name>ap_5.05r409_SSE.exe</name>
        <executable/>
    </file_info>
    <app_version>
        <app_name>astropulse_v505</app_name>
        <version_num>505</version_num>
<platform>windows_intelx86</platform>
        <file_ref>
            <file_name>ap_5.05r409_SSE.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>    
    <app_version>
        <app_name>astropulse_v505</app_name>
        <version_num>505</version_num>
<platform>windows_x86_64</platform>
        <file_ref>
            <file_name>ap_5.05r409_SSE.exe</file_name>
            <main_program/>
        </file_ref>
    </app_version>
<app_info>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>MB_6.10_win_SSE3_ATI_HD5_r177.exe</name>
<executable/>
</file_info>
<file_info>
<name>MultiBeam_Kernels.cl</name>
<executable/>
</file_info>


<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_intelx86</platform>
<avg_ncpus>0.05</avg_ncpus>
<max_ncpus>0.05</max_ncpus>
<plan_class>ati13ati</plan_class>
        <cmdline>-period_iterations_num 2 -instances_per_device 1 -hp</cmdline>
        <flops>20987654321</flops>
<file_ref>
<file_name>MB_6.10_win_SSE3_ATI_HD5_r177.exe</file_name>
<main_program/>
</file_ref>
    <file_ref>
        <file_name>MultiBeam_Kernels.cl</file_name>
        <copy_file/>
    </file_ref>
   <coproc>
   <type>ATI</type>
   <count>1</count>
   </coproc>
</app_version>
<app_info>
<app>
<name>astropulse_v505</name>
</app>
<file_info>
         <name>ap_5.06_win_x86_SSE2_OpenCL_ATI_r456.exe</name>
         <executable/>
     </file_info>
<file_info>
   <name>AstroPulse_Kernels.cl</name>
   <executable/>
</file_info>
     <app_version>
         <app_name>astropulse_v505</app_name>
         <version_num>506</version_num>
<avg_ncpus>0.01</avg_ncpus>
<max_ncpus>0.05</max_ncpus>
                <plan_class>ati13ati</plan_class>
                <cmdline>-ffa_block 8192 -ffa_block_fetch 2048</cmdline>
         <coproc>
           <type>ATI</type>
       <count>1</count>
         </coproc>
       <flops>15987654321</flops>

      <file_ref>
             <file_name>ap_5.06_win_x86_SSE2_OpenCL_ATI_r456.exe</file_name>
             <main_program/>                          
         </file_ref>
<file_ref>
   <file_name>AstroPulse_Kernels.cl</file_name>
   <copy_file/>
</file_ref>
     </app_version>


A wszelkie inne optymalizacje i inne próbki był nie liczone
Zapisane


>>Moja szczegółowa sygnatur<< %)                                      >> Spis moich odkrytych liczb pierwszych << :whistle:

apohawk

  • Leń
  • Newsmani
  • BOINC Fanatyk
  • *
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 3 058
  • Ask no questions, hear no lies.
    • Zobacz profil
AstroPulse na GPU ATI
« Odpowiedź #58 dnia: 10 Lipiec 2011, 23:33 »

Eksperymentowałem trochę z aplikacją multibeam/seti_enhanced (MB_6.10_win_SSE3_ATI_HD5_r177.exe) na ATI OpenCL i mam wrażenie, że to jeszcze nie gotowe. Generalnie, jak wszystkie core'y zajęte, to load na GPU jest 0% i skacze czasem do 20%. Jak zostawię 1 core wolny, to jest lepiej, ale tylko trochę. Największy load na GPU jest, jak zostawię wszystkie core'y wolne, pomimo, że aplikacja nie obciąża żadnego core'a, poza startem aplikacji. Niektóre próbki bardzo przyzwoicie (load 90+%) się liczyły, ale niektóre to tragedia, czyli load 37% i jakieś kompletnie nieakceptowalne i dokuczliwe trzaski przy słuchaniu muzyki. Filmów boję się włączać. Jak jeden włączyłem, gdy eksperymentowałem z odpalaniem dwóch aplikacji jednocześnie, to mi system zdechł.

Myślałem, że podgonię w PM, ale poddaję się. Nieakceptowalne dla mnie problemy ze stabilnością systemu. Punktacja na oko wyszła by 7k na dobę, gdzie w milce wyciągnę 200k na dobę. Może kiedyś dopracują tą aplikację, żeby korzystała z GPU w pełni i nie potrzebowała marnować CPU.
Zapisane
No good deed goes unpunished.
Strony: 1 [2]   Do góry
 

SMF spam blocked by CleanTalk