BOINC@Poland

Zaloguj się lub zarejestruj.

Zaloguj się podając nazwę użytkownika, hasło i długość sesji
Szukanie zaawansowane  

Aktualności:

W MEDIA znajdziesz grafiki, banery i avatary

Strony: [1] 2 3 4 5 ... 7   Do dołu

Autor Wątek: Problemy z czujnikami i sposoby ich rozwiązania...  (Przeczytany 52709 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

emik

  • Newsmani
  • Kalkulator
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 395
    • Zobacz profil
Problemy z czujnikami i sposoby ich rozwiązania...
« dnia: 12 Październik 2011, 14:20 »

czujnik dotarł i już podłączony - czy można jakoś wyłączyć brzęczyk?
« Ostatnia zmiana: 13 Lipiec 2012, 17:45 wysłana przez Szopler »
Zapisane

Szopler

  • Radioaktywny
  • Moderator
  • Kalkulator
  • *
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 545
    • Zobacz profil
    • szoplik.pl
Problemy z czujnikiem Rad@H
« Odpowiedź #1 dnia: 12 Październik 2011, 14:34 »

W preferencjach projektu odznaczyć Buzzer :)
Zapisane

emik

  • Newsmani
  • Kalkulator
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 395
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #2 dnia: 12 Październik 2011, 15:48 »

w jaki sposób można się odznaczyć na mapie z lokalizacją czujników?
Zapisane

Svistak

  • Liczydłowy
  • **
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 660
  • "Dziecko" Prypeci
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #3 dnia: 12 Październik 2011, 16:07 »

Jak przeliczysz i odeślesz pierwszą próbkę, w preferencjach Twojego komputera dojdzie taka opcja z mapą :) ...
To jest chyba Twój komputer - http://radioactiveathome.org/boinc/show_host_detail.php?hostid=2 - i Ty na dole powinieneś mieć już taką opcję :) ...
Zapisane

Niewiele jest na świecie miejsc ciszy i spokoju

www.pripyat.com

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #4 dnia: 12 Październik 2011, 16:13 »

W preferencjach projektu odznaczyć Buzzer :)

Właśnie nie do końca (przynajmniej mi) to działa. Wyłączyłem brzęczyk, wyłączyłem podświetlanie, zaktualizowałem projekt, ba nawet zrestartowałem, żadnych zmian, nadal pika i świeci.
Zapisane

emik

  • Newsmani
  • Kalkulator
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 395
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #5 dnia: 12 Październik 2011, 16:15 »

dzięki - już się odznaczam

gaballus - poczekaj aż pobierze nową próbkę - mi zadziałało
Zapisane

Svistak

  • Liczydłowy
  • **
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 660
  • "Dziecko" Prypeci
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #6 dnia: 12 Październik 2011, 16:24 »

W preferencjach projektu odznaczyć Buzzer :)
Właśnie nie do końca (przynajmniej mi) to działa. Wyłączyłem brzęczyk, wyłączyłem podświetlanie, zaktualizowałem projekt, ba nawet zrestartowałem, żadnych zmian, nadal pika i świeci.
Skoro zrestartowałeś projekt (nie kompa), to sprawdź jeszcze raz preferencje, czy aby Ci nie przywróciło domyślnych. I wtedy ustaw raz jeszcze brak buzzera czy i tez podświetlenia, daj aktualizację projektu, ale nie resetuj, tylko wyłącz Boinca i włącz go na nowo... najlepiej uruchomić ponownie kompa - zawsze na początku będzie pikał przy uruchamianiu kompa, dopóki nie uruchomi się Boinc i nie wczyta konfigurację...
Zapisane

Niewiele jest na świecie miejsc ciszy i spokoju

www.pripyat.com

Svistak

  • Liczydłowy
  • **
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 660
  • "Dziecko" Prypeci
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #7 dnia: 12 Październik 2011, 16:29 »

Dla ułatwienia i kontroli, czy wszystko "gra" - zawsze można zaglądnąć tu - http://radioactiveathome.org/boinc/test123a.php ...
A mapa czujników jest tu - http://radioactiveathome.org/map - będzie nas przybywać  :ahoy:  ...
Zapisane

Niewiele jest na świecie miejsc ciszy i spokoju

www.pripyat.com

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #8 dnia: 12 Październik 2011, 16:41 »

Przebadałem sprawę i moim zdaniem boinc-manager nie widzi czujnika. Czujnik jest wykrywany w systemie prawidłowo. Czy w logu managera powinny pojawić się jakies informacje po wykryciu czujnika?
Zapisane

GRID

  • Administrator
  • Starszy Liczydłowy
  • *
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 2 634
  • Stworzony by pomagać :D
    • Zobacz profil
    • Grid | superkomputer
Problemy z czujnikiem Rad@H
« Odpowiedź #9 dnia: 12 Październik 2011, 16:49 »

w jaki sposób można się odznaczyć na mapie z lokalizacją czujników?
Jeżeli czujnik już zbiera próbki to w szczegółach hosta jest dodawanie czujnika.

emik

  • Newsmani
  • Kalkulator
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 395
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #10 dnia: 12 Październik 2011, 16:51 »

Przebadałem sprawę i moim zdaniem boinc-manager nie widzi czujnika. Czujnik jest wykrywany w systemie prawidłowo. Czy w logu managera powinny pojawić się jakies informacje po wykryciu czujnika?

widzę, że nie dostałeś żadnych punktów więc może podłączyłeś odwrotnie tubę - chociaż nie wiem czy ma to jakieś znaczenie
Zapisane

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #11 dnia: 12 Październik 2011, 16:59 »

widzę, że nie dostałeś żadnych punktów więc może podłączyłeś odwrotnie tubę - chociaż nie wiem czy ma to jakieś znaczenie

Nie, nie, czujnik sam w sobie działa w porządku, wyniki na wyświetlaczu pojawiają się, oscylacje są zliczane. W systemie też czujnik jest widziany:
Bus 003 Device 028: ID 16c0:05df VOTISprawdzałem już na dwóch kompach i jest to samo. Boinc był restartowany. Będę szukał :)

Edit:
po uruchomieniu "ręcznym" aplikacji pojawiają się takie komunikaty w stderr:
17:01:09 (24322): Can't open init data file - running in standalone mode
Radac $Rev: 160 $ starting...
error finding DataStore: The specified device was not found
« Ostatnia zmiana: 12 Październik 2011, 17:05 wysłana przez gaballus »
Zapisane

emik

  • Newsmani
  • Kalkulator
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 395
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #12 dnia: 12 Październik 2011, 17:09 »

u mnie idzie bez problemów

Radac $Rev: 210 $ starting...
263391,88,2011-10-12 15:7:51,1,f,0.000000
304309,105,2011-10-12 15:8:32,2,n,0.008264
Zapisane

Szopler

  • Radioaktywny
  • Moderator
  • Kalkulator
  • *
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 545
    • Zobacz profil
    • szoplik.pl
Problemy z czujnikiem Rad@H
« Odpowiedź #13 dnia: 12 Październik 2011, 17:27 »

po uruchomieniu "ręcznym" aplikacji pojawiają się takie komunikaty w stderr:
17:01:09 (24322): Can't open init data file - running in standalone mode
Radac $Rev: 160 $ starting...
error finding DataStore: The specified device was not found

Chyba koledzy zapomnieli updateować aplikację dla linuksa na serwerze bo urządzenie się teraz nie nazywa "DataStore" tylko "radioactiveathome.org GRS"...
Zapisane

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H
« Odpowiedź #14 dnia: 12 Październik 2011, 17:30 »

no i sprawa jasna :) Czekam w taki razie na update.

Edit:
Widzę że pojawiła się wersja 1.46, ale nic to nie zmieniło, nadal poszukuje urządzenia: DataStore.
« Ostatnia zmiana: 12 Październik 2011, 18:01 wysłana przez gaballus »
Zapisane

Szopler

  • Radioaktywny
  • Moderator
  • Kalkulator
  • *
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 545
    • Zobacz profil
    • szoplik.pl
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #15 dnia: 12 Październik 2011, 21:06 »

Cytat: TJM @ IRC
- wtf ? to jest ze zrodel dzisiejszych, az sam sprawdze...
- no # rzeczywiscie, juz wiem co jest grane, tylko nie wiem dlaczego %-)
- zrodla sa nowe ale usbconfig.h stary...
- za 10 minut bedzie 1.47 i bedzie dziala na 100% %-) mam makefile na linuksie walniety i szuka usbconfig.h w zlym miejscu...

XD
Zapisane

TJM

  • Grupa Reagowania Operacyjno-Manewrowego
  • BOINC Fanatyk
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 3 057
  • Smokin` 5 clients to nachapać more
    • Zobacz profil
    • Enigma@Home
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #16 dnia: 12 Październik 2011, 21:44 »

%)
Aplikacja na linuksie była w starej wersji bo aż do dziś nikt oprócz mnie (poza krótkimi testami) nie użytkował czujnika z Linuksem. Miało to też zalety, Linux był poletkiem doświadczalnym  :ph34r:
Zapisane

W razie jakiejś pilniejszej sprawy - jestem często dostępny na kanale IRC B@P, na forum czasami zapominam zajrzeć lub nie mam czasu.

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #17 dnia: 12 Październik 2011, 21:51 »

 XD

Faktycznie pobrało 1.47, w standalone nie wywala już błędu, zobaczę jak będzie z odesłaną próbką, ale buzzer i podświetlanie nadal olewa moje ustawienia.
Zapisane

krzyszp

  • Wszechstronny dyletant
  • Norway
  • Kalkulator
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 786
    • Zobacz profil
    • Roads Business Software Ltd
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #18 dnia: 12 Październik 2011, 21:54 »

...ale buzzer i podświetlanie nadal olewa moje ustawienia.
To do szuflady z nim - w obecności skarpetek zachowuje się ciszej  ;D

A tak poważnie, to chyba jest w takim razie jakiś błąd w app pod linuksem...
Zapisane


Należę do drużyny BOINC@Poland
 Moja wizytówka

TJM

  • Grupa Reagowania Operacyjno-Manewrowego
  • BOINC Fanatyk
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 3 057
  • Smokin` 5 clients to nachapać more
    • Zobacz profil
    • Enigma@Home
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #19 dnia: 12 Październik 2011, 22:04 »

Faktycznie pobrało 1.47, w standalone nie wywala już błędu, zobaczę jak będzie z odesłaną próbką, ale buzzer i podświetlanie nadal olewa moje ustawienia.

Raczej nie olewa.
Aplikacja w wersji standalone nic nie ustawia, bo nie ma jak (skąd miałaby wziąć preferencje ?). Na przyszłość można zrobić wersję sterowaną z commandline, ale na razie takowej nie ma.
BOINCowa wersja uaktualnia prefsy po każdym kontakcie z serwerem, ale wchodzą w życie wraz z nowym WU.
Zapisane

W razie jakiejś pilniejszej sprawy - jestem często dostępny na kanale IRC B@P, na forum czasami zapominam zajrzeć lub nie mam czasu.

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #20 dnia: 12 Październik 2011, 22:26 »

A tak, zdaję sobie sprawę z ograniczeń odpalenia z palca. Tak sprawdzałem tylko czy widzi czujnik. Odpaliłem później już normalnie, ubiłem WU pobrało nowe ale ustawień nie zaktualizowało, poczekam aż zakończy aktualną próbkę, ale coś mi się zdaje że danych nie wysyła.
Jeszcze taka jedna sprawa, widzę po ręcznym odpaleniu plik data.bin i narastające wartości w ostatniej kolumnie, czy to ilość zliczeń od uruchomienia aplikacji? Już piszę do czego zmierzam: mam kilka termometrów na zewnątrz dojdą teraz czujniki wilgotności ciśnienia kierunku i siły wiatru itp. Wrzucam to wszystko w rrd rysuje wykresy i byłbym bardzo szczęśliwy jakbym mógł tez wyciągnąć z czujnika pomiar promieniowania, tak abym oprócz projektu mógł samodzielnie wrzucić wynik do bazy rrd i później wykorzystać do wykresu, No już w ogóle pięknie by było jakby aplikacja zapisywała do pliku jawnie, w µSv/h :)) Ja pobieram dane z innych czujników co 5 minut gdyby dało się dopisać jakiś fragmencik kodu wysyłający to co idzie na wyświetlacz także do pliku byłbym bardzo wdzięczny.
Zapisane

krzyszp

  • Wszechstronny dyletant
  • Norway
  • Kalkulator
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 786
    • Zobacz profil
    • Roads Business Software Ltd
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #21 dnia: 12 Październik 2011, 22:36 »

Tak, dane w pliku data.bin są jawne (mylące jest rozszerzenie .bin, ale to zwykły plik tekstowy).
Mało tego - na bierząco są aktualizowane dane w tabelce http://radioactiveathome.org/boinc/test123a.php
Zapisane


Należę do drużyny BOINC@Poland
 Moja wizytówka

Svistak

  • Liczydłowy
  • **
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 660
  • "Dziecko" Prypeci
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #22 dnia: 12 Październik 2011, 22:42 »

Tylko, że właśnie patrząc na ową tabelkę nowego kolegi nie "widać" :( ... dziś tylko pojawił się komp o ID 2 nowego kolegi w projekcie - Emika, który już przeliczył min. jedną próbkę i dzięki temu ustawił sobie lokalizację... czyli coś masz nadal nie tak z transferem danych... a wykres w uSv/h możesz mieć taki - podaję swój komp o ID 621:
Zapisane

Niewiele jest na świecie miejsc ciszy i spokoju

www.pripyat.com

TJM

  • Grupa Reagowania Operacyjno-Manewrowego
  • BOINC Fanatyk
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 3 057
  • Smokin` 5 clients to nachapać more
    • Zobacz profil
    • Enigma@Home
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #23 dnia: 12 Październik 2011, 22:49 »

No już w ogóle pięknie by było jakby aplikacja zapisywała do pliku jawnie, w µSv/h :)) Ja pobieram dane z innych czujników co 5 minut gdyby dało się dopisać jakiś fragmencik kodu wysyłający to co idzie na wyświetlacz także do pliku byłbym bardzo wdzięczny.

Problem w tym, że plików w katalogach "slot" nie powinno się ruszać ponieważ powoduje to komplikacje (np. BOINC nie będzie mógł usunąć katalogu po zakończeniu aplikacji, lub co gorsze aplikacja nie da rady otworzyć go do zapisu i się wywali) i na dodatek jest mało przyjazne (sloty zajmowane są losowo - trzeba szukać pliku po wszystkich).

Na potrzeby łatwego pobierania danych jest coś takiego -> http://radioactiveathome.org/boinc/gethostdata.php?hostid=506&ntrickles=100 gdzie pierwsza linijka zawiera trochę przetworzonych danych (kolejność zgodna z "test123a"), a dalej są ewentualnie ostatnie pomiary (można wyłączyć). Format danych da się zmienić na XML przez dodanie xml=1. Dane są aktualizowane przez mechanizm "trickle" a fakt zaktualizowania można wykryć sprawdzając ostatnią wartość w pierwszej linii - jest to unikatowy ID pomiaru.

Format tych danych raczej się nie zmieni bez wcześniejszego ogłoszenia tego faktu (ewentualnie mogą zostać dodane nowe wartości do pierwszej linii, ale w takim razie tylko na końcu), natomiast drobna uwaga - wzory przeliczające są jeszcze "stare" i stąd też inne wartości.
« Ostatnia zmiana: 12 Październik 2011, 22:58 wysłana przez TJM »
Zapisane

W razie jakiejś pilniejszej sprawy - jestem często dostępny na kanale IRC B@P, na forum czasami zapominam zajrzeć lub nie mam czasu.

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #24 dnia: 12 Październik 2011, 23:31 »

Tylko, że właśnie patrząc na ową tabelkę nowego kolegi nie "widać" :( ... dziś tylko pojawił się komp o ID 2 nowego kolegi w projekcie - Emika, który już przeliczył min. jedną próbkę i dzięki temu ustawił sobie lokalizację... czyli coś masz nadal nie tak z transferem danych...

Tak nadal coś jest nie w porządku, będę szukał :dunno:

Na potrzeby łatwego pobierania danych jest coś takiego -> http://radioactiveathome.org/boinc/gethostdata.php?hostid=506&ntrickles=100 gdzie pierwsza linijka zawiera trochę przetworzonych danych (kolejność zgodna z "test123a"), a dalej są ewentualnie ostatnie pomiary (można wyłączyć). Format danych da się zmienić na XML przez dodanie xml=1. Dane są aktualizowane przez mechanizm "trickle" a fakt zaktualizowania można wykryć sprawdzając ostatnią wartość w pierwszej linii - jest to unikatowy ID pomiaru.

Format tych danych raczej się nie zmieni bez wcześniejszego ogłoszenia tego faktu (ewentualnie mogą zostać dodane nowe wartości do pierwszej linii, ale w takim razie tylko na końcu), natomiast drobna uwaga - wzory przeliczające są jeszcze "stare" i stąd też inne wartości.

No to już powinno dać się coś z tego zrobić, pobawię się jak będę miał chwilę czasu.
Dzięki

Edit:
A wzór przeliczający będzie zmieniony czy samemu zapodać formułkę przeliczająca na µSv/h? (w sumie nic prostszego)
« Ostatnia zmiana: 12 Październik 2011, 23:47 wysłana przez gaballus »
Zapisane

Svistak

  • Liczydłowy
  • **
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 660
  • "Dziecko" Prypeci
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #25 dnia: 12 Październik 2011, 23:38 »

Za to pojawił się kolejny liczący - kolega Miszol z kompem o ID 584 - witamy wśród Nas :) ...
Twój wykresik danych układa się tak:

Zapisane

Niewiele jest na świecie miejsc ciszy i spokoju

www.pripyat.com

TJM

  • Grupa Reagowania Operacyjno-Manewrowego
  • BOINC Fanatyk
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 3 057
  • Smokin` 5 clients to nachapać more
    • Zobacz profil
    • Enigma@Home
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #26 dnia: 12 Październik 2011, 23:39 »

Chyba wiem co jest grane.
Manager na linuksie odpalony ze zwykłego usera ?

http://www.boincatpoland.org/smf/radioactivehome/radioactivehome-co-to-jest/msg148446/#msg148446
Zapisane

W razie jakiejś pilniejszej sprawy - jestem często dostępny na kanale IRC B@P, na forum czasami zapominam zajrzeć lub nie mam czasu.

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #27 dnia: 12 Październik 2011, 23:49 »

A zaraz sprawdzę, boinca mam dodanego do plugdeva (mam akcelerometr na tym kompie) ale zobaczę czy wpis w rules.d pomoże.

Edit:
No i chyba zadziałało, w każdym razie czujnik zamilkł i wygasił podświetlanie, czy przekazuje dane zaraz się przekonamy :)
« Ostatnia zmiana: 12 Październik 2011, 23:56 wysłana przez gaballus »
Zapisane

TJM

  • Grupa Reagowania Operacyjno-Manewrowego
  • BOINC Fanatyk
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 3 057
  • Smokin` 5 clients to nachapać more
    • Zobacz profil
    • Enigma@Home
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #28 dnia: 12 Październik 2011, 23:50 »

Według mnie pomoże, na moim laptopie bez wpisu nie działa. Po dopisaniu potrzebny jest jeszcze restart udev.
Zapisane

W razie jakiejś pilniejszej sprawy - jestem często dostępny na kanale IRC B@P, na forum czasami zapominam zajrzeć lub nie mam czasu.

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #29 dnia: 12 Październik 2011, 23:59 »

Po dopisaniu potrzebny jest jeszcze restart udev.

Tak, to jasna jest sprawa skoro się nowa regułkę do udeva dodało :)

Myślę ze trzeba pozbierać te wszystkie informacje w jednym miejscu dla potomności  ;)
Zapisane

Svistak

  • Liczydłowy
  • **
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 660
  • "Dziecko" Prypeci
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #30 dnia: 13 Październik 2011, 00:19 »

Ano - udało Wam się  :respect:  ...
Gaballus - witaj, Twój komp to ID 495 ...
A Twoje pomiary już ładnie spływają:

Zapisane

Niewiele jest na świecie miejsc ciszy i spokoju

www.pripyat.com

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #31 dnia: 13 Październik 2011, 00:44 »

Ano - udało Wam się  :respect:  ...
Gaballus - witaj, Twój komp to ID 495 ...
A Twoje pomiary już ładnie spływają:
:) jeszcze tylko trzeba będzie ustawić położenie na mapie i będzie komplet.
Zapisane

Svistak

  • Liczydłowy
  • **
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 660
  • "Dziecko" Prypeci
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #32 dnia: 13 Październik 2011, 05:58 »

no to do dzieła, kilka próbek masz już policzonych i odesłanych - to teraz klikasz tu - http://radioactiveathome.org/boinc/show_host_detail.php?hostid=495 - i u siebie na kompie na dole powinieneś mieć mapkę. gdzie ustawiasz swoją pozycję i widzimy gdzie mamy kolejną czujkę - http://radioactiveathome.org/map :) ...
Zapisane

Niewiele jest na świecie miejsc ciszy i spokoju

www.pripyat.com

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #33 dnia: 13 Październik 2011, 10:39 »

Położenie ustawione, teraz trzeba by się zastanowić w jakim miejscu najlepiej umieścić tubę. Jeśli robi się urządzenie mobilne, to wiadomo sprawa jasna, ma być wszystko razem w jednej obudowie, ale przy stacjonarnym można by już pokusić się o umieszczenie tuby na zewnątrz w czymś w stylu pagody meteorologicznej. Chyba że się mylę i w umiejscowienie tuby nie ma większego znaczenia (oczywiście nie mówimy o bunkrze z ołowiu)?

Mam jeszcze pytanie do twórców oprogramowania: O  ile większość jest jasna nie mogę rozgryźć parametru std() (w xmlu <host_std>) i jeszcze jeden <duration> (widzę ze to stała a jednak czasami się zmienia).
« Ostatnia zmiana: 13 Październik 2011, 23:29 wysłana przez gaballus »
Zapisane

TJM

  • Grupa Reagowania Operacyjno-Manewrowego
  • BOINC Fanatyk
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 3 057
  • Smokin` 5 clients to nachapać more
    • Zobacz profil
    • Enigma@Home
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #34 dnia: 14 Październik 2011, 09:37 »

Std() to jest standardowa dewiacja, w normalnych warunkach jest dość niska,  dla rur pracujących przy czystym promieniowaniu tła wynosi przeciętnie 3-4. Natomiast wystarczy niewielka nieprawidłowość i zaczyna gwałtownie się zmieniać, czy ma jakieś zastosowanie praktyczne - nie wiem, ale na pewno pomoże wykryć np. fakt uszkodzenia czujnika.
Natomiast czas pomiaru teoretycznie jest stały (40s/20s w wersji debug) ale w praktyce może ciut się wydłużyć - np. kiedy sam manager jest trochę zajęty (kilka uruchomionych zadań), pomiar lekko się wydłuża ponieważ wywołania API mają czasami niewielkie opóźnienie.
Dlatego też czas pomiaru jest floatem i do obliczeń brany jest każdy osobno, nie można z góry przyjmować stałej wartości.
Ponadto pierwszy pomiar jak i pomiary po wznowieniu wstrzymanej aplikacji mają czasami zupełnie inny, dużo dłuższy czas.
Zapisane

W razie jakiejś pilniejszej sprawy - jestem często dostępny na kanale IRC B@P, na forum czasami zapominam zajrzeć lub nie mam czasu.

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #35 dnia: 14 Październik 2011, 09:46 »

Dzięki.
Czyli wychodzi na to że wartość duration (w większości wypadków 0.660) wyrażana jest w minutach :)
Zapisane

TJM

  • Grupa Reagowania Operacyjno-Manewrowego
  • BOINC Fanatyk
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 3 057
  • Smokin` 5 clients to nachapać more
    • Zobacz profil
    • Enigma@Home
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #36 dnia: 14 Październik 2011, 11:55 »

No dokładnie, czas pomiaru jest w minutach. Jeżeli wszystko śmiga bez żadnych dodatkowych opóźnień, wynosi 2/3 minuty czyli 0.666  :ph34r:
Zapisane

W razie jakiejś pilniejszej sprawy - jestem często dostępny na kanale IRC B@P, na forum czasami zapominam zajrzeć lub nie mam czasu.

gaballus

  • Bywalec forum
  • *****
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 219
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #37 dnia: 14 Październik 2011, 13:43 »

Dobra, jeszcze tylko jedno pytanie i na jakiś czas powinienem dać spokój  ;) 1 impuls na minutę (lub jakikolwiek inny okres) jakiej dawce odpowiada? Wiem że można to wyciągnąć ze źródeł, ale nie jestem programistą i zajęło by mi to tydzień ślęczenia :)
« Ostatnia zmiana: 14 Październik 2011, 13:54 wysłana przez gaballus »
Zapisane

Tomasz R. Gwiazda

  • Kalkulator
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 5 971
    • Zobacz profil
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #38 dnia: 14 Październik 2011, 14:05 »

ja to mam skrecone juz , podlaczone do kompa, app sciagniete.
Pika (co prawda to wylaczelem i odswiezylem ale nadal pika) co jakis czas i pokazuje 0,09 uSv/h  to znaczy ze dziala ? :)


krzyszp

  • Wszechstronny dyletant
  • Norway
  • Kalkulator
  • ***
  • Offline Offline
  • Płeć: Mężczyzna
  • Wiadomości: 7 786
    • Zobacz profil
    • Roads Business Software Ltd
Problemy z czujnikiem Rad@H i sposoby ich rozwiązania
« Odpowiedź #39 dnia: 14 Październik 2011, 14:31 »

10 impulsów przez 35.04 sekundy odpowieda 0,10mSv/h

0,09 jest w normie (do ok. 0,35)
Zapisane


Należę do drużyny BOINC@Poland
 Moja wizytówka
Strony: [1] 2 3 4 5 ... 7   Do góry
 

SMF spam blocked by CleanTalk